Netatalk 3.0 alpha2 を動かしてみる

突然、サーバ系の話。

どうにも Mac から Samba サーバに接続するとイヤなことが多いので、やはり Netatalk を使ってみようと思い立った。サイトを見ると 3.0 alpha2 がリリースされていたので調べてみると、あの変なフォルダなどができなくなったらしい。英文を読んだので自信はないが、拡張属性を使って処理しているようだ。リソースフォークはダメみたいだけれど、今リソースフォークを使うアプリもなかろうということでチャレンジ!

まず、avahi を入れておく。

$ sudo apt-get install avahi-daemon libnss-mdns

で、必要そうなモノを入れてから、Netatalk のインストールをおこなう。

$ sudo apt-get install libssl-dev libgcrypt11-dev libpam0g-dev libwrap0-dev libdb4.8-dev libavahi-client-dev libacl1-dev libldap2-dev libkrb5-dev

ソースを展開。

$ tar xzf netatalk-3.0alpha2.tar.gz
$ cd netatalk-3.0alpha2
$ ./configure –with-init-style=debian

DHX2 も入っているし、大丈夫でしょう。

$ make
$ sudo make install

なんの問題もなく進みます。/usr/local/etc/afp.conf を編集。Glocal セクションで「mac charset = MAC_JAPANESE」と修正して、公開するフォルダの設定。

2012.04.10 以下の設定は Netatalk 自体が avahi に対応したので必要ないそうです。

あとは /etc/avahi/services/afpd.service をつくる。内容は以下のようにしたが、まったく自信がない。

<?xml version=”1.0″ standalone=’no’?><!–*-nxml-*–>
<!DOCTYPE service-group SYSTEM “avahi-service.dtd”>
<service-group>
<name replace-wildcards=”yes”>%h</name>
<service>
<type>_afpovertcp._tcp</type>
<port>548</port>
</service>
</service-group>

で、/etc/init.d/netatalk start すると、起動。なんの問題もないようです。

しかし、Lion から接続しようとすると、エラーが発生して接続できない。DHX2 も効いているはずなのに…

2 時間ほど悩んで、Netatalk の第一人者 HAT さんのサイトの Netatalk 3.0 and Samba を見る。が、やっていることは同じようだ。ちょっと気になったのが、Blog の方の Debian 6 squeezeに Netatalk 3.0 alpha2 を入れる という記事でプロンプトが「#」になっている(sudo とか使っているんだけど)。ということで、make uninstall して、root で再ビルドしてインストールしたところ、Lion からも接続できるようになりました。原因が一般ユーザでのビルドにあるのかどうかは不明ですが、とりあえず使えるようになった。

そして、TimeMachine 用の設定も書いてあったので、それも使ってみています(本稼働とは思っていない)。

4 コメント

HAT2012年4月10日 21:14

プロンプトが#になってるのは間違いです。あとで直します。一般ユーザで作業してます。

エラーが発生して接続できない件ですが、
http://sourceforge.net/tracker/?func=detail&aid=3515051&group_id=8642&atid=108642
にあるように、make installしたときUAMのシンボリックリンクが作られない場合があるようで、認証が通らないのでエラーになります。make installをもう一度実行するとシンボリックリンクが作られるようです。
私のところではalpha1で発生し、alpha2では発生しませんでした。どうも再現条件がわかりません。

あと、/etc/avahi/services/afpd.serviceは作らないでください。これは2.1.xの頃の古い情報です。2.2.x以降はAvahi対応なので、このファイルを作らなくても自動的に登録されます。

ところで、このサーバはDebianですか? それともUbuntuですか?

ngn2012年4月10日 22:13

> HAT さん

有益な情報を提供していただいて、感謝しています。

このサーバは Debian (Squeeze) です。ちなみに VMWare ESXi 上で動かしています。
別なサーバでも同様なことを行ったのですが、一回目から正しくインストールされ問題は発生しませんでした。こちらも Debian (Squeeze) です。

HAT2012年4月13日 21:53

シンボリックの件ですが、原因が判明し、
http://marc.info/?l=netatalk&m=133424651606031&w=2
修正されました。
http://netatalk.git.sourceforge.net/git/gitweb.cgi?p=netatalk/netatalk;a=commitdiff;h=3f02db8555bf21577823d9de0f456a3f15c5531f;hp=b0cff4c2076dfd5d05f900f612eb8e8cf828fcf9
次のバージョンでは問題ないです。

HAT2013年3月17日 22:51

netatalk日本語メーリングリストというのを開設しましたが、いかがでしょう。
http://www003.upp.so-net.ne.jp/hat/netatalk/ja-ml.html
開設して間もないですが、ぼちぼち成果がでています。

コメントを残す

あなたのコメント